SpringBoot + ES

版本!

尝试过高版本的7.3.1和低版本的2.4.4,都不行

最终选择适合SpringBoot 2.1.3版本的es是5.6.16!

要不然高版本报错:None of the configured nodes are available

低版本相对友好一些,会报:Received message from unsupported version: [5.6.0] minimal compatible versio 提示该换版本了

代码地址:https://github.com/zby123456/Spring-Boot.git

搜索:

controller
service
dao

部分demo截图:

增加数据
根据title来搜索
索引名和type

127.0.0.1:9200/articleindex/article/_search 检索所有

_search :查看所有节点

You may also like...

发表评论

电子邮件地址不会被公开。 必填项已用*标注